summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary Lowell <glowell@inktank.com>2012-10-08 22:56:05 -0700
committerGary Lowell <glowell@inktank.com>2012-10-15 14:14:35 -0700
commit071fdc217a2401fb53876a4b5906ebcefec57667 (patch)
treebf4e9f3a4af8179a050107741609436cbe14786c /configure.ac
parent7ea734c472b4bd34b87b8ef3352c4df65931f800 (diff)
downloadceph-071fdc217a2401fb53876a4b5906ebcefec57667.tar.gz
Makefile: Improve test for boost system library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9bf808990f2..cc7236824c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,7 +364,8 @@ AC_CHECK_HEADER([boost/statechart/state.hpp], [],
# If we have the boost system library installed, then we may want to link
# with it.
AC_CHECK_LIB(boost_system-mt, main, [],
- AC_MSG_NOTICE(["Boost system library not found."]))
+ [AC_CHECK_LIB(boost_system, main, [],
+ AC_MSG_NOTICE(["Boost system library not found."]))])
AC_LANG([C])