summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoah Watkins <noahwatkins@gmail.com>2012-11-02 12:52:38 -0700
committerJoe Buck <jbbuck@gmail.com>2012-11-08 09:28:26 -0800
commit1581db9bcb467828a22f9705b6205e7c43aa10a5 (patch)
tree5f0310a54b14a5feb75673537f2533d675282fc4 /configure.ac
parenta47a96619cbd680b478da906436b874c57c697f2 (diff)
downloadceph-1581db9bcb467828a22f9705b6205e7c43aa10a5.tar.gz
configure: fail when missing junit dependency
Signed-off-by: Noah Watkins <noahwatkins@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0d5eb9a38d9..4fa0c0d463a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -285,12 +285,19 @@ AS_IF([test "x$enable_cephfs_java" = "xyes"], [
# cephfs_java_test only makes sense if java is already turned on
# setup CLASSPATH for Debian default junit4.jar package
+ #
+ # Configuring --with-debug and --enable-cephfs-java will throw an error if
+ # JUnit4 cannot be found. While currently this works for users who have
+ # installed via the package manager on Ubuntu, we need to expand this
+ # check to 1) support other distrubtions and 2) allow users to influence
+ # the search path.
AS_IF([test "x$with_debug" = "xyes"], [
dir='/usr/share/java'
junit4_jar=`find $dir -name junit4.jar | head -n 1`
AS_IF([test -r "$junit4_jar"], [
EXTRA_CLASSPATH_JAR=`dirname $junit4_jar`/junit4.jar
- AC_SUBST(EXTRA_CLASSPATH_JAR)])])
+ AC_SUBST(EXTRA_CLASSPATH_JAR)], [
+ AC_MSG_ERROR([Cannot find junit4.jar (apt-get install junit4)])])])
# Check for Java programs: javac, javah, jar
PATH_save=$PATH