summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJoe Buck <jbbuck@gmail.com>2012-11-01 17:14:10 -0700
committerJoe Buck <jbbuck@gmail.com>2012-11-08 09:27:49 -0800
commit5dec9172d94bb7cdb72eba74f19cdce53f85b127 (patch)
treeb27a42d3b194148b6d218aa4bf6bfbc039eafd4e /configure.ac
parent08ee7364bc8c561dcdaefe829278e7bcc4459282 (diff)
downloadceph-5dec9172d94bb7cdb72eba74f19cdce53f85b127.tar.gz
Moving test java files into a proper heirarchy. Moving the compilation
of tests classes from build.xml to Makefile and editing configure.ac to look for the junit4 jar in the default location of /usr/share/java. It is still possible to build and run tests from build.xml as well as Makefile. Signed-off-by: Joe Buck <jbbuck@gmail.com> Reviewed-by: Noah Watkins <noahwatkins@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 26b720748f1..0d5eb9a38d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -283,6 +283,15 @@ AS_IF([test "x$enable_cephfs_java" = "xyes"], [
AS_IF([test -r "$jnih"], [
EXTRA_JDK_INC_DIR=`dirname $jnih`])])
+ # cephfs_java_test only makes sense if java is already turned on
+ # setup CLASSPATH for Debian default junit4.jar package
+ AS_IF([test "x$with_debug" = "xyes"], [
+ dir='/usr/share/java'
+ junit4_jar=`find $dir -name junit4.jar | head -n 1`
+ AS_IF([test -r "$junit4_jar"], [
+ EXTRA_CLASSPATH_JAR=`dirname $junit4_jar`/junit4.jar
+ AC_SUBST(EXTRA_CLASSPATH_JAR)])])
+
# Check for Java programs: javac, javah, jar
PATH_save=$PATH
PATH="$PATH:$EXTRA_JDK_BIN_DIR"