summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDanny Al-Gaaf <danny.al-gaaf@bisect.de>2013-01-04 18:51:31 +0100
committerGary Lowell <glowell@inktank.com>2013-01-09 17:13:11 -0800
commit61437ee24e4f1c887fd431f5dc2dc4827bdbbfa5 (patch)
tree4618d79c30d1da440dc3628d44cacf65f05bf0fc /configure.ac
parentaedbb97fe662d369022f45179da16cf6abb87cc6 (diff)
downloadceph-61437ee24e4f1c887fd431f5dc2dc4827bdbbfa5.tar.gz
configure.ac: change junit4 handling
Change handling of --with-debug and junit4. Add a new conditional HAVE_JUNIT4 to be able to build ceph-test package also if junit4 isn't available. In this case simply don't build libcephfs-test.jar, but the rest of the tools. Signed-off-by: Danny Al-Gaaf <danny.al-gaaf@bisect.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 15430ddc173..832054b2926 100644
--- a/configure.ac
+++ b/configure.ac
@@ -309,8 +309,10 @@ AS_IF([test "x$enable_cephfs_java" = "xyes"], [
junit4_jar=`find $dir -name junit4.jar | head -n 1`
AS_IF([test -r "$junit4_jar"], [
EXTRA_CLASSPATH_JAR=`dirname $junit4_jar`/junit4.jar
- AC_SUBST(EXTRA_CLASSPATH_JAR)], [
- AC_MSG_ERROR([Cannot find junit4.jar (apt-get install junit4)])])])
+ AC_SUBST(EXTRA_CLASSPATH_JAR)
+ [have_junit4=1]], [
+ AC_MSG_NOTICE([Cannot find junit4.jar (apt-get install junit4)])
+ [have_junit4=0]])])
# Check for Java programs: javac, javah, jar
PATH_save=$PATH
@@ -341,6 +343,7 @@ AS_IF([test "x$enable_cephfs_java" = "xyes"], [
# Setup output var
AC_SUBST(JDK_CPPFLAGS)
])
+AM_CONDITIONAL(HAVE_JUNIT4, [test "$have_junit4" = "1"])
# jni?
# clear cache (from java above) -- this whole thing will get