summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Just <sam.just@inktank.com>2012-10-31 10:27:33 -0700
committerSamuel Just <sam.just@inktank.com>2012-10-31 10:27:33 -0700
commit6bbe7db79dd2516fcb0410cb8eef48fca3b696c6 (patch)
tree9ecf4c32b3f834bffd9693c9d00774f6289353d1 /configure.ac
parentfd4b839d04525f5ca9069bad82b2f7f7f8ae8689 (diff)
downloadceph-6bbe7db79dd2516fcb0410cb8eef48fca3b696c6.tar.gz
configure.ac: add program_options header check
Signed-off-by: Samuel Just <sam.just@inktank.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eed9752d40f..26b720748f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,6 +436,8 @@ AC_CHECK_HEADER([boost/random/discrete_distribution.hpp],
AC_CHECK_HEADER([boost/statechart/state.hpp], [],
AC_MSG_FAILURE(["Can't find boost statechart headers; need 1.34 or later"]))
+AC_CHECK_HEADER([boost/program_options/option.hpp], [],
+ AC_MSG_FAILURE(["Can't find boost program_options headers"]))
# If we have the boost system library installed, then we may want to link
# with it.