summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary Lowell <gary.lowell@inktank.com>2012-11-16 00:46:41 -0800
committerGary Lowell <glowell@inktank.com>2012-11-16 10:51:42 -0800
commit8b187bd8ca0f81bf623de8405fdc611a130b219f (patch)
treeef7f6cb6c2a6077ff09d1000981702f7df01630e /configure.ac
parent71cfaf1cc5b1d77676aaf0be6daa15d4ab303386 (diff)
downloadceph-8b187bd8ca0f81bf623de8405fdc611a130b219f.tar.gz
build: update for boost_thread library.
There is a difference in naming conventions between debian and rpm based distributions for this library. In configure.ac we check first for boost_thread-mt, then if it's not found check for boost_thread. A side effect of the AC_CEHCK_LIB macro is to add the library to the $LIBS, so the explicit -llibboost_thread in the Makefile has been removed. (cherry picked from commit f0c7bb363000037bbf7d58ac6e2d39d0f10200fe)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 430ba1eb010..aa101434495 100644
--- a/configure.ac
+++ b/configure.ac
@@ -467,6 +467,11 @@ AC_CHECK_LIB(boost_system-mt, main, [],
[AC_CHECK_LIB(boost_system, main, [],
AC_MSG_NOTICE(["Boost system library not found."]))])
+# Find the right boost_thread library.
+AC_CHECK_LIB(boost_thread-mt, main, [],
+ [AC_CHECK_LIB(boost_thread, main, [],
+ AC_MSG_FAILURE(["Boost thread library not found."]))])
+
AC_LANG([C])
AC_CHECK_MEMBER([struct fiemap_extent.fe_logical],