summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary Lowell <glowell@inktank.com>2013-02-10 22:21:52 -0800
committerGary Lowell <glowell@inktank.com>2013-02-25 19:35:34 -0800
commitaa79077c2442e518c11f3d1885461d734909370b (patch)
tree4880f67cb5d65e5e2d708156edf97105e866ed73 /configure.ac
parentccdafa067afed74b209537ae45ff8b49bb5fab3b (diff)
downloadceph-aa79077c2442e518c11f3d1885461d734909370b.tar.gz
configure.ac: Add test for c++ compiler.
The AC_PROG_CXX macro sets a flag if a C++ compiler is found but does not fail if one is not found, it left to application to test the flags as needed. This fix will issue an error when a c++ compiler is not found. Bug 3955. Signed-off-by: Gary Lowell <gary.lowell@inktank.com> it's not installed, this fix adds an error message for a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eeed31fd55c..2d445e55b0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,10 @@ AM_CONDITIONAL(FREEBSD, test x"$freebsd" = x"yes")
# Checks for programs.
AC_PROG_CXX
+if test "$CXX" = no || test "$CXX:$GXX" = "g++:"; then
+ AC_MSG_ERROR([no C++ compiler found])
+fi
+
#AC_PROG_CC
AC_PROG_MAKE_SET
AC_PROG_LIBTOOL