summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary Lowell <gary.lowell@inktank.com>2012-10-16 23:27:21 +0000
committerGary Lowell <gary.lowell@inktank.com>2012-10-16 23:27:21 +0000
commitd78ba6af94129435586acf576beb177129e817cf (patch)
tree63c763bc639e28d07a875f52eebd0a5888591410 /configure.ac
parentab4d8b75f377bb4aa20e986ab7aff5dab899673c (diff)
parent2528b5ee105b16352c91af064af5c0b5a7d45d7c (diff)
downloadceph-d78ba6af94129435586acf576beb177129e817cf.tar.gz
Merge branch 'next'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4d03635b761..63d7a12d387 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,7 +8,8 @@ AC_PREREQ(2.59)
# NOTE: This version is _only_ used for naming the tarball. The
# VERSION define is not used by the code. It gets a version string
# from 'git describe'; see src/ceph_ver.[ch]
-AC_INIT([ceph], [0.52], [ceph-devel@vger.kernel.org])
+AC_INIT([ceph], [0.53], [ceph-devel@vger.kernel.org])
+AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SUBDIRS([src/gtest])
AC_CONFIG_SUBDIRS([src/leveldb])
@@ -360,6 +361,12 @@ AC_CHECK_HEADER([boost/random/discrete_distribution.hpp],
AC_CHECK_HEADER([boost/statechart/state.hpp], [],
AC_MSG_FAILURE(["Can't find boost statechart headers; need 1.34 or later"]))
+# If we have the boost system library installed, then we may want to link
+# with it.
+AC_CHECK_LIB(boost_system-mt, main, [],
+ [AC_CHECK_LIB(boost_system, main, [],
+ AC_MSG_NOTICE(["Boost system library not found."]))])
+
AC_LANG([C])
AC_CHECK_MEMBER([struct fiemap_extent.fe_logical],