summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDanny Al-Gaaf <danny.al-gaaf@bisect.de>2013-01-28 16:33:42 +0100
committerSage Weil <sage@inktank.com>2013-01-28 13:56:32 -0800
commitf74265b08ab3679bb28a913ab436d185ea37ea9b (patch)
tree0c6f9d3c420e64afe980f97b6fac77c2970a513e /configure.ac
parentfb85c7f6cfe959cc63ce8bf637d852411ed102e7 (diff)
downloadceph-f74265b08ab3679bb28a913ab436d185ea37ea9b.tar.gz
configure: fix check for fuse_getgroups()
Check for fuse_getgroups() only in case we have found libfuse already. Moved the check to the check for --with-fuse. Small fix: fix string for NO_ATOMIC_OPS, don't use "'". Signed-off-by: Danny Al-Gaaf <danny.al-gaaf@bisect.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ffbd150502f..cb49a0b2fe1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,6 +241,8 @@ AS_IF([test "x$with_fuse" != xno],
AC_DEFINE([HAVE_LIBFUSE], [1],
[Define if you have fuse])
HAVE_LIBFUSE=1
+ # look for fuse_getgroups and define FUSE_GETGROUPS if found
+ AC_CHECK_FUNCS([fuse_getgroups])
],
[AC_MSG_FAILURE(
[no FUSE found (use --without-fuse to disable)])])])
@@ -391,7 +393,8 @@ AS_IF([test "x$with_libatomic_ops" != xno],
])])
AS_IF([test "$HAVE_ATOMIC_OPS" = "1"],
[],
- AC_DEFINE([NO_ATOMIC_OPS], [1], [Defined if you don't have atomic_ops]))
+ [AC_DEFINE([NO_ATOMIC_OPS], [1], [Defined if you do not have atomic_ops])])
+
AM_CONDITIONAL(WITH_LIBATOMIC, [test "$HAVE_ATOMIC_OPS" = "1"])
# newsyn? requires mpi.
@@ -417,9 +420,6 @@ AS_IF([test "x$with_system_leveldb" = xcheck],
[AC_CHECK_LIB([leveldb], [leveldb_open], [with_system_leveldb=yes], [], [-lsnappy -lpthread])])
AM_CONDITIONAL(WITH_SYSTEM_LEVELDB, [ test "$with_system_leveldb" = "yes" ])
-# look for fuse_getgroups and define FUSE_GETGROUPS if found
-AC_CHECK_FUNCS([fuse_getgroups])
-
# use system libs3?
AC_ARG_WITH([system-libs3],
[AS_HELP_STRING([--with-system-libs3], [use system libs3])],