summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary Lowell <glowell@inktank.com>2012-11-08 12:43:24 -0800
committerGary Lowell <glowell@inktank.com>2012-11-08 12:43:24 -0800
commitff5ee98f1c97b286a81848dc3b70ea523d8fe95e (patch)
treeabb13aefefd3b13326680608128027ac63790a00 /configure.ac
parent8db7d2c43641343cb5de113f932e4f854b8027a0 (diff)
downloadceph-ff5ee98f1c97b286a81848dc3b70ea523d8fe95e.tar.gz
build: Add RPM release string generated from git describe.
Fix for bug 3451. Use the commit count and sha1 from git describe to construct a release string for rpm packages.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4fa0c0d463a..46a244bfef1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,11 @@ AC_PREREQ(2.59)
# VERSION define is not used by the code. It gets a version string
# from 'git describe'; see src/ceph_ver.[ch]
AC_INIT([ceph], [0.53], [ceph-devel@vger.kernel.org])
+
+# Create release string. Used with VERSION for RPMs.
+AC_SUBST(RPM_RELEASE)
+RPM_RELEASE=`if expr index $(git describe --always) '-' > /dev/null ; then git describe --always | cut -d- -f2- | tr '-' '.' ; fi`
+
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SUBDIRS([src/gtest])