summaryrefslogtreecommitdiff
path: root/src/pybind/cephfs/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'src/pybind/cephfs/setup.py')
-rw-r--r--src/pybind/cephfs/setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/pybind/cephfs/setup.py b/src/pybind/cephfs/setup.py
new file mode 100644
index 00000000000..bbd96dbb9ee
--- /dev/null
+++ b/src/pybind/cephfs/setup.py
@@ -0,0 +1,32 @@
+from setuptools import setup, find_packages
+import os
+
+
+def long_description():
+ readme = os.path.join(os.path.dirname(__file__), 'README.rst')
+ return open(readme).read()
+
+
+setup(
+ name = 'cephfs',
+ description = 'Bindings for cephfs [ceph]',
+ packages=find_packages(),
+ author = 'Inktank',
+ author_email = 'ceph-devel@vger.kernel.org',
+ version = '0.67', #XXX Fix version
+ license = "LGPL2",
+ zip_safe = False,
+ keywords = "ceph, cephfs, bindings, api, cli",
+ long_description = long_description(),
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU Lesser General Public License v2 (LGPLv2)',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Utilities',
+ 'Topic :: System :: Filesystems',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ ],
+)