diff options
author | Ned Batchelder <ned@nedbatchelder.com> | 2021-12-31 09:17:07 -0500 |
---|---|---|
committer | Ned Batchelder <ned@nedbatchelder.com> | 2021-12-31 09:17:07 -0500 |
commit | 4d38f23251046ec48a73cd1db5773a68d58130e5 (patch) | |
tree | 882dee1ba4d7811dd006cf7fad81835d978a05e2 /setup.py | |
parent | c2773105682ee01b5ebfe5d29e86a9634d02b053 (diff) | |
download | python-coveragepy-git-nedbat/drop-36.tar.gz |
build: drop Python 3.6 supportnedbat/drop-36
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -32,6 +32,7 @@ if bool(int(os.getenv("COVERAGE_QUIETER", "0"))): # Get or massage our metadata. We exec coverage/version.py so we can avoid # importing the product code into setup.py. +# PYVERSIONS classifiers = """\ Environment :: Console Intended Audience :: Developers @@ -39,7 +40,6 @@ License :: OSI Approved :: Apache Software License Operating System :: OS Independent Programming Language :: Python Programming Language :: Python :: 3 -Programming Language :: Python :: 3.6 Programming Language :: Python :: 3.7 Programming Language :: Python :: 3.8 Programming Language :: Python :: 3.9 @@ -77,7 +77,7 @@ elif version_info[3] in ['beta', 'candidate']: else: assert version_info[3] == 'final' devstat = "5 - Production/Stable" -classifier_list.append("Development Status :: " + devstat) +classifier_list.append(f"Development Status :: {devstat}") # Create the keyword arguments for setup() @@ -132,7 +132,7 @@ setup_args = dict( 'Issues': 'https://github.com/nedbat/coveragepy/issues', 'Twitter': 'https://twitter.com/coveragepy', }, - python_requires=">=3.6", + python_requires=">=3.7", # minimum of PYVERSIONS ) # A replacement for the build_ext command which raises a single exception |