summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2009-03-05 21:21:43 -0500
committerNed Batchelder <ned@nedbatchelder.com>2009-03-05 21:21:43 -0500
commit0cc8fd18714cb214327a0a58b704401a9efdf8dc (patch)
tree0a6ac59eaf1b7acaf26053a5f3c69304b9ddbda3 /setup.py
downloadpython-coveragepy-git-0cc8fd18714cb214327a0a58b704401a9efdf8dc.tar.gz
Initial coverage.py 3.0 beta 1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py60
1 files changed, 60 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..2f0aeed5
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,60 @@
+# setup.py for coverage.
+
+"""\
+Code coverage testing for Python
+
+Coverage.py is a Python package that measures code coverage during test execution.
+It uses the code analysis tools and tracing hooks provided in the Python standard
+library to determine which lines are executable, and which have been executed.
+"""
+
+classifiers = """\
+Development Status :: 5 - Production/Stable
+Environment :: Console
+Intended Audience :: Developers
+License :: OSI Approved :: BSD License
+Operating System :: OS Independent
+Programming Language :: Python
+Topic :: Software Development :: Quality Assurance
+Topic :: Software Development :: Testing
+"""
+
+from ez_setup import use_setuptools
+use_setuptools()
+
+from setuptools import setup, find_packages
+from distutils.core import Extension
+
+from coverage import __version__
+
+doclines = __doc__.split("\n")
+
+setup(
+ name = 'coverage',
+ version = __version__,
+
+ packages = [
+ 'coverage',
+ ],
+
+ entry_points={
+ 'console_scripts': [
+ 'coverage = coverage:main',
+ ]
+ },
+ zip_safe = True, # __file__ appears in the source, but doesn't break zippy-ness.
+
+ ext_modules = [
+ Extension("coverage.tracer", sources=["coverage/tracer.c"])
+ ],
+
+ author = 'Ned Batchelder',
+ author_email = 'ned@nedbatchelder.com',
+ description = doclines[0],
+ long_description = "\n".join(doclines[2:]),
+ keywords = 'code coverage testing',
+ license = 'BSD',
+ classifiers = filter(None, classifiers.split("\n")),
+ url = 'http://nedbatchelder.com/code/modules/coverage.html',
+ download_url = 'http://nedbatchelder.com/code/modules/coverage-%s.tar.gz' % __version__,
+)