summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2019-03-10 14:27:18 -0400
committerGitHub <noreply@github.com>2019-03-10 14:27:18 -0400
commit2cab54c755607dccdf2cf29711b72f8bf42c9cf5 (patch)
tree2887e319bcca8800a3db071de4ef4a39aca3bf6c /setup.py
parent6541759acef3ff4f957441d9b1844acaf3ecb8a4 (diff)
parentb140512e4205664d37452d3f4c7ca4e0daf078e8 (diff)
downloadpython-coveragepy-git-2cab54c755607dccdf2cf29711b72f8bf42c9cf5.tar.gz
Merge branch 'master' into travis-xenial
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 9 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 77dcab3d..7655c4e1 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,6 @@ Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
-Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@@ -103,11 +102,19 @@ setup_args = dict(
author_email='ned@nedbatchelder.com',
description=doc,
long_description=long_description,
+ long_description_content_type='text/x-rst',
keywords='code coverage testing',
license='Apache 2.0',
classifiers=classifier_list,
url="https://github.com/nedbat/coveragepy",
-
+ project_urls={
+ 'Documentation': __url__,
+ 'Funding': (
+ 'https://tidelift.com/subscription/pkg/pypi-coverage'
+ '?utm_source=pypi-coverage&utm_medium=referral&utm_campaign=pypi'
+ ),
+ 'Issues': 'https://github.com/nedbat/coveragepy/issues',
+ },
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, <4",
)