diff options
author | Ned Batchelder <ned@nedbatchelder.com> | 2009-07-09 09:38:19 -0400 |
---|---|---|
committer | Ned Batchelder <ned@nedbatchelder.com> | 2009-07-09 09:38:19 -0400 |
commit | 2dd34c19fdacc7d34665b0a7eb07cee065da36a8 (patch) | |
tree | 443709420f163ced119070faf44784975972d975 /setup.py | |
parent | 9f9d56f31f3e5ddca5ffa253b804f54f7c47cbbe (diff) | |
download | python-coveragepy-git-2dd34c19fdacc7d34665b0a7eb07cee065da36a8.tar.gz |
Setup.py should be linted too
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -25,10 +25,11 @@ Topic :: Software Development :: Testing import sys if sys.hexversion < 0x03000000: + # In Py 2.x, use setuptools. from ez_setup import use_setuptools use_setuptools() - from setuptools import setup, find_packages + from setuptools import setup from distutils.core import Extension setuptools_args = dict( @@ -38,9 +39,11 @@ if sys.hexversion < 0x03000000: ] }, - zip_safe = False, # we need to get HTML assets from our htmlfiles dir. + # We need to get HTML assets from our htmlfiles dir. + zip_safe = False, ) else: + # No setuptools yet for Py 3.x, so do without. from distutils.core import setup, Extension setuptools_args = {} |