summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2009-12-13 17:21:58 -0500
committerNed Batchelder <ned@nedbatchelder.com>2009-12-13 17:21:58 -0500
commit5e5c26966ee3d75c17ca33c9d49f8926aefe735b (patch)
tree96e9e9a8550523a6ade00967c823f875d207e330 /setup.py
parent9e134e3f40f34a560860efdb48874f8332629ba4 (diff)
downloadpython-coveragepy-git-5e5c26966ee3d75c17ca33c9d49f8926aefe735b.tar.gz
version_info is a nicer way to check Python versions than hexversion is.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2d4efaed..4c1a9187 100644
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,7 @@ import sys
# Distribute is a new fork of setuptools. It's supported on Py3.x, so we use
# it there, but stick with classic setuptools on Py2.x until Distribute becomes
# more accepted.
-if sys.hexversion > 0x03000000:
+if sys.version_info >= (3, 0):
from distribute_setup import use_setuptools
else:
from ez_setup import use_setuptools