summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJulian Berman <Julian+Hg@GrayVines.com>2012-10-28 20:48:49 -0400
committerJulian Berman <Julian+Hg@GrayVines.com>2012-10-28 20:48:49 -0400
commit605735c5afbb865f172e9b30d9174915c16ad1c7 (patch)
treea970e35fa328efd2bc352f2fe7f0c5881fa37d5e /setup.py
parented69ae75ac040c6dbc5921d21f8966c517beb1c0 (diff)
downloadpython-coveragepy-git-605735c5afbb865f172e9b30d9174915c16ad1c7.tar.gz
Create coverage3 symlink when installed using Python 3
--HG-- branch : coverage3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 1d4e9efd..67745515 100644
--- a/setup.py
+++ b/setup.py
@@ -55,6 +55,10 @@ from distutils.core import Extension # pylint: disable=E0611,F0401
from coverage import __url__, __version__
+scripts = ['coverage = coverage:main']
+if sys.version_info >= (3, 0):
+ scripts.append('coverage3 = coverage:main')
+
doclines = (__doc__ % __url__).split('\n')
classifier_list = [c for c in classifiers.split("\n") if c]
@@ -83,11 +87,7 @@ setup_args = dict(
]
},
- entry_points = {
- 'console_scripts': [
- 'coverage = coverage:main',
- ],
- },
+ entry_points = {'console_scripts': scripts},
# We need to get HTML assets from our htmlfiles dir.
zip_safe = False,