summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2012-12-20 07:15:47 -0500
committerNed Batchelder <ned@nedbatchelder.com>2012-12-20 07:15:47 -0500
commita1f6641ca9d2e5cc395671ab6fe82b65949552a4 (patch)
tree3573e3e30f695c6eb08b1580932a978b536eb90c /setup.py
parent2827bb6e678c1233fc8d54961a39c37c3d78b908 (diff)
downloadpython-coveragepy-git-a1f6641ca9d2e5cc395671ab6fe82b65949552a4.tar.gz
Properly create an Exception.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 53f08f9b..62db5e7b 100644
--- a/setup.py
+++ b/setup.py
@@ -121,7 +121,7 @@ if sys.platform == 'win32' and sys.version_info > (2, 6):
class BuildFailed(Exception):
"""Raise this to indicate the C extension wouldn't build."""
def __init__(self):
- Exception.__init__()
+ Exception.__init__(self)
self.cause = sys.exc_info()[1] # work around py 2/3 different syntax
class ve_build_ext(build_ext.build_ext):