summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2009-09-20 18:05:07 -0400
committerNed Batchelder <ned@nedbatchelder.com>2009-09-20 18:05:07 -0400
commitbb83d13bf720acb8d15173cc4d1484b8521f8930 (patch)
treec2bffaa2b52bea16efa559397d6e12ee9452d1fd /setup.py
parent4dadb9ab49529ccdfd4bc7a23f0d799051b24757 (diff)
downloadpython-coveragepy-git-bb83d13bf720acb8d15173cc4d1484b8521f8930.tar.gz
New theory about how to kit for py3k: coverage3k-* kits are for 3.x
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 6 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 254c9f72..5e815a86 100644
--- a/setup.py
+++ b/setup.py
@@ -24,7 +24,7 @@ Topic :: Software Development :: Testing
"""
# Pull in the tools we need.
-import sys
+import os, sys
if sys.hexversion < 0x03000000:
# In Py 2.x, use setuptools.
@@ -34,6 +34,7 @@ if sys.hexversion < 0x03000000:
from setuptools import setup
from distutils.core import Extension
+ package_name = 'coverage'
# The 2.x sources are in coverage
coverage_dir = "coverage"
@@ -51,8 +52,9 @@ else:
# No setuptools yet for Py 3.x, so do without.
from distutils.core import setup, Extension
- # The 3.x sources are in py3k
- coverage_dir = "py3k"
+ package_name = 'coverage3k'
+ # The 3.x sources are in coverage
+ coverage_dir = "coverage"
more_setup_args = dict(
scripts = [
@@ -80,7 +82,7 @@ classifier_list.append("Development Status :: " + devstat)
# Set it up!
setup(
- name = 'coverage',
+ name = package_name,
version = __version__,
packages = [