diff options
author | Ned Batchelder <ned@nedbatchelder.com> | 2009-03-06 07:33:12 -0500 |
---|---|---|
committer | Ned Batchelder <ned@nedbatchelder.com> | 2009-03-06 07:33:12 -0500 |
commit | d451b16c807912f016d9afd6b01e8d7a92046b5a (patch) | |
tree | eddfb79f8dd325a4dce329440fef2e953200efb9 /setup.py | |
parent | de397ee8e5b267aee0fbf84b0203e6a2a2aa64a6 (diff) | |
download | python-coveragepy-git-d451b16c807912f016d9afd6b01e8d7a92046b5a.tar.gz |
Compute the dev status from the version number, and other minor tweaks.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 23 |
1 files changed, 19 insertions, 4 deletions
@@ -8,7 +8,6 @@ library to determine which lines are executable, and which have been executed. """ classifiers = """ -Development Status :: 5 - Production/Stable Environment :: Console Intended Audience :: Developers License :: OSI Approved :: BSD License @@ -18,16 +17,32 @@ Topic :: Software Development :: Quality Assurance Topic :: Software Development :: Testing """ +# Pull in the tools we need. + from ez_setup import use_setuptools use_setuptools() from setuptools import setup, find_packages from distutils.core import Extension +# Get or massage our metadata. + from coverage import __version__ doclines = __doc__.split("\n") +classifier_list = filter(None, classifiers.split("\n")) + +if 'a' in __version__: + devstat = "3 - Alpha" +elif 'b' in __version__: + devstat = "4 - Beta" +else: + devstat = "5 - Production/Stable" +classifier_list.append("Development Status :: " + devstat) + +# Set it up! + setup( name = 'coverage', version = __version__, @@ -41,19 +56,19 @@ setup( 'coverage = coverage:main', ] }, - zip_safe = True, # __file__ appears in the source, but doesn't break zippy-ness. - ext_modules = [ Extension("coverage.tracer", sources=["coverage/tracer.c"]) ], + zip_safe = True, # __file__ appears in the source, but doesn't break zippy-ness. + author = 'Ned Batchelder', author_email = 'ned@nedbatchelder.com', description = doclines[0], long_description = "\n".join(doclines[2:]), keywords = 'code coverage testing', license = 'BSD', - classifiers = filter(None, classifiers.split("\n")), + classifiers = classifier_list, url = 'http://nedbatchelder.com/code/modules/coverage.html', download_url = 'http://nedbatchelder.com/code/modules/coverage-%s.tar.gz' % __version__, ) |