summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2009-09-22 07:22:56 -0400
committerNed Batchelder <ned@nedbatchelder.com>2009-09-22 07:22:56 -0400
commitff9099051e0daff7b08035713eeca5696ab3217a (patch)
tree13a391e9010e9e0b99ff403ec2fd0252d460ab5a /setup.py
parente3c0b4b2c7d2a92344d30a25467a1e863bbb7d31 (diff)
downloadpython-coveragepy-git-ff9099051e0daff7b08035713eeca5696ab3217a.tar.gz
The best way to get py3k support: same source runs on both, with some contortions.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 1 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 5440e574..9cf491ca 100644
--- a/setup.py
+++ b/setup.py
@@ -34,8 +34,6 @@ if sys.hexversion < 0x03000000:
from setuptools import setup
from distutils.core import Extension
- package_name = 'coverage'
-
more_setup_args = dict(
entry_points = {
'console_scripts': [
@@ -50,8 +48,6 @@ else:
# No setuptools yet for Py 3.x, so do without.
from distutils.core import setup, Extension
- package_name = 'coverage3k'
-
more_setup_args = dict(
scripts = [
'scripts/coverage',
@@ -78,7 +74,7 @@ classifier_list.append("Development Status :: " + devstat)
# Set it up!
setup(
- name = package_name,
+ name = 'coverage',
version = __version__,
packages = [