summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2018-01-11 06:05:14 -0800
committerJon Dufresne <jon.dufresne@gmail.com>2018-01-11 06:05:14 -0800
commitfbad065c9acccbb3092b78af69b923b23451902c (patch)
tree95ebdcabdb04abf467caadcee835652c0c49f873 /setup.py
parentde242a2676b7f0605bd536a07e5faddef79aae2e (diff)
downloadpython-coveragepy-git-fbad065c9acccbb3092b78af69b923b23451902c.tar.gz
Pass python_requires argument to setuptools
Helps pip decide what version of the library to install. https://packaging.python.org/tutorials/distributing-packages/#python-requires > If your project only runs on certain Python versions, setting the > python_requires argument to the appropriate PEP 440 version specifier > string will prevent pip from installing the project on other Python > versions. https://setuptools.readthedocs.io/en/latest/setuptools.html#new-and-changed-setup-keywords > python_requires > > A string corresponding to a version specifier (as defined in PEP 440) > for the Python version, used to specify the Requires-Python defined in > PEP 345.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 90bed3dc..9d158dfc 100644
--- a/setup.py
+++ b/setup.py
@@ -106,6 +106,8 @@ setup_args = dict(
license='Apache 2.0',
classifiers=classifier_list,
url="https://bitbucket.org/ned/coveragepy",
+
+ python_requires=">=2.6, !=3.0.*, !=3.1.*, !=3.2.*",
)
# A replacement for the build_ext command which raises a single exception