summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 7 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index c4a2288d..c8527819 100644
--- a/setup.py
+++ b/setup.py
@@ -74,6 +74,12 @@ else:
devstat = "5 - Production/Stable"
classifier_list.append("Development Status :: " + devstat)
+# Install a script as "coverage", and as "coverage[23]"
+scripts = [
+ 'coverage = coverage:main',
+ 'coverage%d = coverage:main' % sys.version_info[0],
+ ]
+
# Create the keyword arguments for setup()
setup_args = dict(
@@ -90,11 +96,7 @@ setup_args = dict(
]
},
- entry_points = {
- 'console_scripts': [
- 'coverage = coverage:main',
- ],
- },
+ entry_points = {'console_scripts': scripts},
# We need to get HTML assets from our htmlfiles dir.
zip_safe = False,