summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 11 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index e6645cfc..822b1da5 100644
--- a/setup.py
+++ b/setup.py
@@ -63,7 +63,7 @@ classifier_list.append("Development Status :: " + devstat)
# Set it up!
-setup(
+setup_args = dict(
name = 'coverage',
version = __version__,
@@ -77,10 +77,6 @@ setup(
]
},
- ext_modules = [
- Extension("coverage.tracer", sources=["coverage/tracer.c"])
- ],
-
entry_points = {
'console_scripts': [
'coverage = coverage:main',
@@ -99,3 +95,13 @@ setup(
classifiers = classifier_list,
url = __url__,
)
+
+# Is there a duck-typing way to know we can't compile extensions?
+if not sys.platform.startswith('java'):
+ setup_args.update(dict(
+ ext_modules = [
+ Extension("coverage.tracer", sources=["coverage/tracer.c"])
+ ],
+ ))
+
+setup(**setup_args)