summaryrefslogtreecommitdiff
path: root/coverage/control.py
Commit message (Collapse)AuthorAgeFilesLines
...
* Exec'ing code gives the wrong filename. A warning now, while we figure it ↵Ned Batchelder2015-07-021-0/+5
| | | | out. Part of #380.
* COVERAGE_DEBUG can set the debug configuration optionsNed Batchelder2015-06-141-0/+3
|
* Debugging plugin wrappersNed Batchelder2015-06-141-1/+1
|
* Change FileLocator from a class to module-level functionsNed Batchelder2015-06-131-16/+13
|
* Move plugin support stuff into plugin_support.pyNed Batchelder2015-06-131-48/+1
|
* PyContracts now uses six, so exclude six during testing.Ned Batchelder2015-06-031-3/+5
|
* Add a docstringNed Batchelder2015-05-251-0/+1
|
* Normalize measured data's filenames before adding to data.Ned Batchelder2015-05-251-3/+6
|
* Use PyContracts so we can declare/enforce parameter and return types.Ned Batchelder2015-05-171-5/+10
| | | | | This commit doesn't add any uses of PyContracts, but gets the machinery in place.
* Update docstring and command line help text.Christine Lytwynec2015-04-221-0/+4
| | | | | --HG-- branch : combine-from-multiple-dirs
* Added ability to combine coverage data files from multiple directories into ↵Christine Lytwynec2015-04-211-2/+2
| | | | | | | one file via command line args. --HG-- branch : combine-from-multiple-dirs
* Handle exceptions from dynamic_source_filename.Ned Batchelder2015-02-261-13/+13
| | | | This required disabling plugins from the C tracer.
* Ensure all FileReporter's have a .name attributeNed Batchelder2015-02-221-6/+14
|
* Rename CodeUnit to FileReporterNed Batchelder2015-02-211-3/+3
|
* Get rid of CodeUnit, FileReporter is the new thing.Ned Batchelder2015-02-211-1/+1
|
* Disable plugins if we can't support them, and show that in debug output.Ned Batchelder2015-02-211-4/+11
|
* Don't need this variableNed Batchelder2015-02-191-1/+1
|
* Protect against misbehaving plugins.Ned Batchelder2015-02-151-18/+36
| | | | | Also, test some misbehavior, and move our own annotations of plugins into prefixed attributes.
* Treat config_file=".coveragerc" the same as config_file=True. #357Ned Batchelder2015-02-111-4/+17
|
* Fix a bad check that was causing mysterious py2/py3 differencesNed Batchelder2015-02-101-2/+2
|
* Show file_tracers in debug sysNed Batchelder2015-02-091-0/+3
|
* Plugin support is now only in the CTracer, not in the PyTracer.Ned Batchelder2015-02-091-0/+9
|
* Plugin support is in C tracer as well as Python tracerNed Batchelder2015-02-081-6/+0
|
* Plugin modules have to define a Plugin class, or an error happens.Ned Batchelder2015-02-081-0/+4
|
* Useful debugging help.Ned Batchelder2015-02-081-0/+10
|
* A better comment.Ned Batchelder2015-02-071-1/+1
|
* Clean up some pylint complaintsNed Batchelder2015-02-021-4/+8
|
* Simplify the plugin selection logic.Ned Batchelder2015-02-011-32/+26
|
* Make process_startup idempotent, to fix #340.Ned Batchelder2015-02-011-5/+24
|
* Wildly experimental multiprocessing support. Covers most of #117.Ned Batchelder2015-01-301-1/+9
|
* Give a reasonable warning for a previous assert. Closes #353.Ned Batchelder2015-01-261-6/+3
|
* Set timid=True automatically for pluginsNed Batchelder2015-01-241-2/+12
| | | | | This is better than asking people to add timid=True to their configs, since this way they won't have to clean it out of their config later.
* Change sysinfo to sys_infoNed Batchelder2015-01-241-3/+3
|
* Plugins can provide sysinfoNed Batchelder2015-01-241-0/+4
|
* Make the two forms of debug output more uniformNed Batchelder2015-01-241-4/+8
|
* Collect all the nudgy environment checks into coverage.envNed Batchelder2015-01-181-1/+2
|
* Properly deal with .pyc files missing their sources.Ned Batchelder2015-01-181-9/+25
|
* When finding the source for a frame, really check if it existsNed Batchelder2015-01-171-5/+12
|
* Move base-class logic from CodeUnit to FileReporterNed Batchelder2015-01-091-2/+2
|
* Start formalizing the FileReporter interface to simplify thingsNed Batchelder2015-01-021-2/+2
|
* Move python source understanding into python.pyNed Batchelder2015-01-011-1/+2
|
* Move code_unit_factory into CoverageNed Batchelder2015-01-011-10/+49
|
* Be a little clearer about when we expect one thing, and when we expect a listNed Batchelder2015-01-011-1/+1
|
* Move Plugins so that plugin.py is just interface definitionsNed Batchelder2015-01-011-1/+38
|
* pep8Ned Batchelder2015-01-011-27/+43
|
* A few more filenames as %s instead of %rNed Batchelder2014-12-281-1/+1
|
* Make sure check_include isn't called more than once per file.Ned Batchelder2014-11-281-0/+2
|
* Changed my mind again about what to name should_trace, and check_include.Ned Batchelder2014-11-281-11/+10
|
* Rename should_trace and check_include_omit_etc to be more parallel.Ned Batchelder2014-11-281-8/+8
|
* OK, I should really stop fiddling with spell-check...Ned Batchelder2014-11-271-1/+1
|