summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNejc Habjan <hab.nejc@gmail.com>2021-08-22 18:01:40 +0200
committerNejc Habjan <hab.nejc@gmail.com>2021-08-22 18:01:40 +0200
commitca475fc80ac556392fb8cb74731f6c66ce010646 (patch)
tree4b836b4b688fe420e7ebd6fdcd04781bb01f29f6
parent616be1ae320ed65e0b213fb4e4d9ebb69bcdad8a (diff)
downloadgitlab-chore/fix-mypy-pre-commit.tar.gz
chore: define root dir in mypy, not toxchore/fix-mypy-pre-commit
-rw-r--r--pyproject.toml1
-rw-r--r--tox.ini2
2 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0cd4c1b..27b5faa 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -6,6 +6,7 @@ order_by_type = false
[tool.mypy]
disallow_incomplete_defs = true
disallow_untyped_defs = true
+files = "."
[[tool.mypy.overrides]] # Overrides for currently untyped modules
module = [
diff --git a/tox.ini b/tox.ini
index 4cb6cd8..1ddc331 100644
--- a/tox.ini
+++ b/tox.ini
@@ -41,7 +41,7 @@ basepython = python3
envdir={toxworkdir}/lint
deps = -r{toxinidir}/requirements-lint.txt
commands =
- mypy {posargs} .
+ mypy {posargs}
[testenv:twine-check]
basepython = python3