summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Wittig <max.wittig@siemens.com>2020-10-08 18:26:24 +0200
committerMax Wittig <max.wittig@siemens.com>2020-10-08 18:27:47 +0200
commit6ef025716ce46772ca0de64ac82dbdeb9fc0f073 (patch)
tree7c066f76816055657eb3205997f5e976dd6ca2c8
parent2002098a19f7a9302d373a867ab1a6f87848b6a0 (diff)
downloadgitlab-chore/test-3-9.tar.gz
chore(ci): test 3.9 and nightly python versionschore/test-3-9
-rw-r--r--.travis.yml33
-rw-r--r--tox.ini2
2 files changed, 25 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index 09359b5..3f30d17 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -14,7 +14,7 @@ jobs:
include:
- stage: lint
name: commitlint
- python: 3.8
+ python: 3.9
script:
- pip3 install pre-commit
- pre-commit run --hook-stage manual commitlint-travis
@@ -24,28 +24,28 @@ jobs:
- stage: lint
name: black_lint
dist: bionic
- python: 3.8
+ python: 3.9
script:
- pip3 install -U --pre black==20.8b1
- black --check .
- stage: test
name: cli_func_v4
dist: bionic
- python: 3.8
+ python: 3.9
script:
- pip3 install tox
- tox -e cli_func_v4
- stage: test
name: py_func_v4
dist: bionic
- python: 3.8
+ python: 3.9
script:
- pip3 install tox
- tox -e py_func_v4
- stage: test
name: cli_func_nightly
dist: bionic
- python: 3.8
+ python: 3.9
env: GITLAB_TAG=nightly
script:
- pip3 install tox
@@ -53,7 +53,7 @@ jobs:
- stage: test
name: py_func_nightly
dist: bionic
- python: 3.8
+ python: 3.9
env: GITLAB_TAG=nightly
script:
- pip3 install tox
@@ -61,7 +61,7 @@ jobs:
- stage: test
name: docs
dist: bionic
- python: 3.8
+ python: 3.9
script:
- pip3 install tox
- tox -e docs
@@ -88,8 +88,22 @@ jobs:
- tox -e py38
- stage: test
dist: bionic
+ name: py39
+ python: 3.9
+ script:
+ - pip3 install tox
+ - tox -e py38
+ - stage: test
+ dist: bionic
+ name: py-nightly
+ python: nightly
+ script:
+ - pip3 install tox
+ - tox -e py38
+ - stage: test
+ dist: bionic
name: twine-check
- python: 3.8
+ python: 3.9
script:
- pip3 install tox wheel
- python3 setup.py sdist bdist_wheel
@@ -97,7 +111,7 @@ jobs:
- stage: test
dist: bionic
name: coverage
- python: 3.8
+ python: 3.9
install:
- pip3 install tox codecov
script:
@@ -106,3 +120,4 @@ jobs:
- codecov
allow_failures:
- env: GITLAB_TAG=nightly
+ - name: py-nightly
diff --git a/tox.ini b/tox.ini
index 92196e5..8c437d4 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
minversion = 1.6
skipsdist = True
-envlist = py38,py37,py36,pep8,black,twine-check
+envlist = py39,py38,py37,py36,pep8,black,twine-check
[testenv]
passenv = GITLAB_IMAGE GITLAB_TAG