summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGauvain Pocentek <gauvain.pocentek@objectif-libre.com>2015-05-11 19:51:21 +0200
committerGauvain Pocentek <gauvain.pocentek@objectif-libre.com>2015-05-11 19:56:21 +0200
commitd2e5700c68f33b0872616fedc6a3320c84c81de6 (patch)
treeccc04bca14c092f6d14eeaaf4db81a5dda1f8da8 /setup.py
parent105896f59bd3399c7d76934e515dab57bcd4f594 (diff)
downloadgitlab-d2e5700c68f33b0872616fedc6a3320c84c81de6.tar.gz
gitlab is now a package
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 8 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 4330e6c..141f111 100644
--- a/setup.py
+++ b/setup.py
@@ -3,14 +3,13 @@
from setuptools import setup
+import gitlab
+
+
def get_version():
- f = open('gitlab.py')
- try:
- for line in f:
- if line.startswith('__version__'):
- return eval(line.split('=')[-1])
- finally:
- f.close()
+
+ return gitlab.__version__
+
setup(name='python-gitlab',
version=get_version(),
@@ -20,8 +19,8 @@ setup(name='python-gitlab',
author_email='gauvain@pocentek.net',
license='LGPLv3',
url='https://github.com/gpocentek/python-gitlab',
- py_modules=['gitlab'],
- scripts=['gitlab'],
+ packages=['gitlab'],
+ scripts=['bin/gitlab'],
install_requires=['requests', 'six'],
classifiers=[
'Development Status :: 5 - Production/Stable',