diff options
author | John L. Villalovos <john@sodarock.com> | 2021-11-08 21:03:44 -0800 |
---|---|---|
committer | John L. Villalovos <john@sodarock.com> | 2021-11-14 16:14:18 -0800 |
commit | 06184daafd5010ba40bb39a0768540b7e98bd171 (patch) | |
tree | d943062b06805898b523755a80bac936a868344c /setup.py | |
parent | f7756680d4b1d23ea3216458fb5c6bd73f709d5e (diff) | |
download | gitlab-jlvillal/mypy_setup.tar.gz |
chore: add type-hints to setup.py and check with mypyjlvillal/mypy_setup
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -4,11 +4,14 @@ from setuptools import find_packages, setup -def get_version(): +def get_version() -> str: + version = "" with open("gitlab/__version__.py") as f: for line in f: if line.startswith("__version__"): - return eval(line.split("=")[-1]) + version = eval(line.split("=")[-1]) + break + return version with open("README.rst", "r") as readme_file: |