diff options
author | Max Wittig <max.wittig95@gmail.com> | 2019-05-16 18:00:34 +0200 |
---|---|---|
committer | Max Wittig <max.wittig95@gmail.com> | 2019-05-16 18:03:56 +0200 |
commit | 318d2770cbc90ae4d33170274e214b9d828bca43 (patch) | |
tree | c5b6d6d9b57f6642dca83ea33956a4d5ae15e5eb /setup.py | |
parent | ef32990347d0ab9145b8919d25269766dc2ce445 (diff) | |
download | gitlab-refactor/black.tar.gz |
refactor: format everything blackrefactor/black
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 68 |
1 files changed, 33 insertions, 35 deletions
@@ -6,43 +6,41 @@ from setuptools import find_packages def get_version(): - with open('gitlab/__init__.py') as f: + with open("gitlab/__init__.py") as f: for line in f: - if line.startswith('__version__'): - return eval(line.split('=')[-1]) + if line.startswith("__version__"): + return eval(line.split("=")[-1]) + with open("README.rst", "r") as readme_file: readme = readme_file.read() -setup(name='python-gitlab', - version=get_version(), - description='Interact with GitLab API', - long_description=readme, - author='Gauvain Pocentek', - author_email='gauvain@pocentek.net', - license='LGPLv3', - url='https://github.com/python-gitlab/python-gitlab', - packages=find_packages(), - install_requires=['requests>=2.4.2', 'six'], - entry_points={ - 'console_scripts': [ - 'gitlab = gitlab.cli:main' - ] - }, - classifiers=[ - 'Development Status :: 5 - Production/Stable', - 'Environment :: Console', - 'Intended Audience :: System Administrators', - 'License :: OSI Approved :: GNU Lesser General Public License v3 (LGPLv3)', - 'Natural Language :: English', - 'Operating System :: POSIX', - 'Operating System :: Microsoft :: Windows', - 'Programming Language :: Python', - 'Programming Language :: Python :: 2', - 'Programming Language :: Python :: 2.7', - 'Programming Language :: Python :: 3', - 'Programming Language :: Python :: 3.4', - 'Programming Language :: Python :: 3.5', - 'Programming Language :: Python :: 3.6', - ] - ) +setup( + name="python-gitlab", + version=get_version(), + description="Interact with GitLab API", + long_description=readme, + author="Gauvain Pocentek", + author_email="gauvain@pocentek.net", + license="LGPLv3", + url="https://github.com/python-gitlab/python-gitlab", + packages=find_packages(), + install_requires=["requests>=2.4.2", "six"], + entry_points={"console_scripts": ["gitlab = gitlab.cli:main"]}, + classifiers=[ + "Development Status :: 5 - Production/Stable", + "Environment :: Console", + "Intended Audience :: System Administrators", + "License :: OSI Approved :: GNU Lesser General Public License v3 (LGPLv3)", + "Natural Language :: English", + "Operating System :: POSIX", + "Operating System :: Microsoft :: Windows", + "Programming Language :: Python", + "Programming Language :: Python :: 2", + "Programming Language :: Python :: 2.7", + "Programming Language :: Python :: 3", + "Programming Language :: Python :: 3.4", + "Programming Language :: Python :: 3.5", + "Programming Language :: Python :: 3.6", + ], +) |