summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml8
-rw-r--r--README.rst5
-rw-r--r--setup.py1
-rw-r--r--tox.ini10
4 files changed, 21 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index d4480a8..8170bab 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -85,6 +85,14 @@ jobs:
- tox -e py38
- stage: test
dist: bionic
+ name: twine-check
+ python: 3.8
+ script:
+ - pip3 install tox wheel
+ - python3 setup.py sdist bdist_wheel
+ - tox -e twine-check
+ - stage: test
+ dist: bionic
name: coverage
python: 3.8
install:
diff --git a/README.rst b/README.rst
index d8a0358..c98ff31 100644
--- a/README.rst
+++ b/README.rst
@@ -130,8 +130,9 @@ passing tests are mandatory to get merge requests accepted.
We're currently in a restructing phase for the unit tests. If you're changing existing
tests, feel free to keep the current format. Otherwise please write new tests with pytest and
-using `responses<https://github.com/getsentry/responses>`_. An example for new tests can be found in
-tests/objects/test_runner.py
+using `responses
+<https://github.com/getsentry/responses/>`_.
+An example for new tests can be found in tests/objects/test_runner.py
You need to install ``tox`` to run unit tests and documentation builds locally:
diff --git a/setup.py b/setup.py
index 6b57373..9626083 100644
--- a/setup.py
+++ b/setup.py
@@ -20,6 +20,7 @@ setup(
version=get_version(),
description="Interact with GitLab API",
long_description=readme,
+ long_description_content_type="text/x-rst",
author="Gauvain Pocentek",
author_email="gauvain@pocentek.net",
license="LGPLv3",
diff --git a/tox.ini b/tox.ini
index 27988cb..df7ca09 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
minversion = 1.6
skipsdist = True
-envlist = py38,py37,py36,pep8,black
+envlist = py38,py37,py36,pep8,black,twine-check
[testenv]
passenv = GITLAB_IMAGE GITLAB_TAG
@@ -27,6 +27,14 @@ deps = -r{toxinidir}/requirements.txt
commands =
black {posargs} gitlab tools/functional
+[testenv:twine-check]
+basepython = python3
+deps = -r{toxinidir}/requirements.txt
+ -r{toxinidir}/test-requirements.txt
+ twine
+commands =
+ twine check dist/*
+
[testenv:venv]
commands = {posargs}