summaryrefslogtreecommitdiff
path: root/docs/install.rst
diff options
context:
space:
mode:
Diffstat (limited to 'docs/install.rst')
-rw-r--r--docs/install.rst19
1 files changed, 12 insertions, 7 deletions
diff --git a/docs/install.rst b/docs/install.rst
index 2a91372..acd2528 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -8,14 +8,19 @@ Use :command:`pip` to install the latest stable version of ``python-gitlab``:
.. code-block:: console
- $ sudo pip install --upgrade python-gitlab
+ $ pip install --upgrade python-gitlab
-The current development version is available on `github
-<https://github.com/python-gitlab/python-gitlab>`__. Use :command:`git` and
-:command:`python setup.py` to install it:
+The current development version is available on both `GitHub.com
+<https://github.com/python-gitlab/python-gitlab>`__ and `GitLab.com
+<https://gitlab.com/python-gitlab/python-gitlab>`__, and can be
+installed directly from the git repository:
.. code-block:: console
- $ git clone https://github.com/python-gitlab/python-gitlab
- $ cd python-gitlab
- $ sudo python setup.py install
+ $ pip install git+https://github.com/python-gitlab/python-gitlab.git
+
+From GitLab:
+
+.. code-block:: console
+
+ $ pip install git+https://gitlab.com/python-gitlab/python-gitlab.git