summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml79
1 files changed, 61 insertions, 18 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3bbe356..77f6b2c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,63 @@
+[build-system]
+requires = ["setuptools>=61.0.0"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "python-gitlab"
+description="A python wrapper for the GitLab API"
+readme = "README.rst"
+authors = [
+ {name = "Gauvain Pocentek", email= "gauvain@pocentek.net"}
+]
+maintainers = [
+ {name = "John Villalovos", email="john@sodarock.com"},
+ {name = "Max Wittig", email="max.wittig@siemens.com"},
+ {name = "Nejc Habjan", email="nejc.habjan@siemens.com"},
+ {name = "Roger Meier", email="r.meier@siemens.com"}
+]
+requires-python = ">=3.7.0"
+dependencies = [
+ "requests>=2.25.0",
+ "requests-toolbelt>=0.9.1"
+]
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Console",
+ "Intended Audience :: System Administrators",
+ "License :: OSI Approved :: GNU Lesser General Public License v3 (LGPLv3)",
+ "Natural Language :: English",
+ "Operating System :: POSIX",
+ "Operating System :: Microsoft :: Windows",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10"
+]
+keywords = ["api", "client", "gitlab", "python", "python-gitlab", "wrapper"]
+license = {file = "COPYING"}
+dynamic = ["version"]
+
+[project.optional-dependencies]
+autocompletion = ["argcomplete>=1.10.0,<3"]
+yaml = ["PyYaml>=5.2"]
+
+[project.scripts]
+gitlab = "gitlab.cli:main"
+
+[project.urls]
+Homepage = "https://github.com/python-gitlab/python-gitlab"
+Changelog = "https://github.com/python-gitlab/python-gitlab/blob/main/CHANGELOG.md"
+Documentation = "https://python-gitlab.readthedocs.io"
+Source = "https://github.com/python-gitlab/python-gitlab"
+
+[tool.setuptools.packages.find]
+exclude = ["docs*", "tests*"]
+
+[tool.setuptools.dynamic]
+version = { attr = "gitlab._version.__version__" }
+
[tool.isort]
profile = "black"
multi_line_output = 3
@@ -6,24 +66,7 @@ order_by_type = false
[tool.mypy]
files = "."
exclude = "build/.*"
-
-# 'strict = true' is equivalent to the following:
-check_untyped_defs = true
-disallow_any_generics = true
-disallow_incomplete_defs = true
-disallow_subclassing_any = true
-disallow_untyped_decorators = true
-disallow_untyped_defs = true
-no_implicit_optional = true
-no_implicit_reexport = true
-strict_equality = true
-warn_redundant_casts = true
-warn_return_any = true
-warn_unused_configs = true
-warn_unused_ignores = true
-
-# The following need to have changes made to be able to enable them:
-# disallow_untyped_calls = true
+strict = true
[[tool.mypy.overrides]] # Overrides for currently untyped modules
module = [