summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Musso <hashar@free.fr>2014-07-25 10:54:44 +0200
committerAntoine Musso <hashar@free.fr>2014-07-25 10:54:44 +0200
commitdbd784b870a878ef6dbecd14310018cdaeda5c6d (patch)
treeacda721c64b6a877196fc26c193e608d4c54de53
parent27c577dfd5c7f0fc75cd10ed6606674b56b405bd (diff)
downloadgitpython-dbd784b870a878ef6dbecd14310018cdaeda5c6d.tar.gz
List runtime dependencies in requirements.txt
More and more packages are listing their dependencies in requirements.txt which make it trivial to maintain and install them.
-rw-r--r--MANIFEST.in1
-rw-r--r--README.md10
-rw-r--r--requirements.txt2
-rw-r--r--setup.py4
4 files changed, 13 insertions, 4 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 89f5b92d..95b2e883 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -3,6 +3,7 @@ include LICENSE
include CHANGES
include AUTHORS
include README
+include requirements.txt
graft git/test/fixtures
graft git/test/performance
diff --git a/README.md b/README.md
index d2a858bf..0b5f5a2a 100644
--- a/README.md
+++ b/README.md
@@ -14,16 +14,20 @@ The object database implementation is optimized for handling large quantities of
* Mock by Michael Foord used for tests
- Tested with 1.0.1
+The list of dependencies are listed in /requirements.txt. The installer takes care of installing them for you though.
+
### INSTALL
If you have downloaded the source code:
python setup.py install
-
-or if you want to obtain a copy more easily:
+
+or if you want to obtain a copy from the Pypi repository:
pip install gitpython
-
+
+Both commands will install the required package dependencies.
+
A distribution package can be obtained for manual installation at:
http://pypi.python.org/pypi/GitPython
diff --git a/requirements.txt b/requirements.txt
new file mode 100644
index 00000000..67f5eb74
--- /dev/null
+++ b/requirements.txt
@@ -0,0 +1,2 @@
+# Remember to update README.md
+gitdb>=0.5.1
diff --git a/setup.py b/setup.py
index e7c927b1..58a763e4 100644
--- a/setup.py
+++ b/setup.py
@@ -16,6 +16,8 @@ v = open(path.join(path.dirname(__file__), 'VERSION'))
VERSION = v.readline().strip()
v.close()
+with open('requirements.txt') as reqs_file:
+ requirements = reqs_file.read().splitlines()
class build_py(_build_py):
def run(self):
@@ -73,7 +75,7 @@ setup(name = "GitPython",
package_data = {'git.test' : ['fixtures/*']},
package_dir = {'git':'git'},
license = "BSD License",
- install_requires='gitdb >= 0.5.1',
+ install_requires=requirements,
zip_safe=False,
long_description = """\
GitPython is a python library used to interact with Git repositories""",