summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES5
-rw-r--r--README18
-rwxr-xr-xsetup.py4
3 files changed, 14 insertions, 13 deletions
diff --git a/CHANGES b/CHANGES
index cc910888..65a80c1e 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,5 +1,2 @@
Please see the online documentation for the latest changelog:
-http://packages.python.org/GitPython/0.3/changes.html
-
-To see the changes of this very version, have a look at the file:
-doc/source/changes.rst
+http://packages.python.org/GitPython/
diff --git a/README b/README
index 531ea8f9..e0f2947d 100644
--- a/README
+++ b/README
@@ -2,16 +2,16 @@
GitPython
==========
-GitPython is a python library used to interact with Git repositories.
+GitPython is a python library used to interact with git repositories, high-level like git-porcelain, or low-level like git-plumbing.
-GitPython is a port of the grit library in Ruby created by
-Tom Preston-Werner and Chris Wanstrath.
+It provides abstractions of git objects for easy access of repository data, and additionally allows you to access the git repository more directly using either a pure python implementation, or the faster, but more resource intensive git command implementation.
+The object database implementation is optimized for handling large quantities of objects and large datasets, which is achieved by using low-level structures and data streaming.
REQUIREMENTS
============
-* Git ( tested with 1.5.3.7 )
+* Git ( tested with 1.7.3.2 )
* Python Nose - used for running the tests
* Mock by Michael Foord used for tests. Requires 0.5
@@ -32,17 +32,21 @@ A distribution package can be obtained for manual installation at:
SOURCE
======
-GitPython's git repo is available on Gitorious and GitHub, which can be browsed at:
+GitPython's git repo is available on GitHub, which can be browsed at:
-http://gitorious.org/projects/git-python/
http://github.com/Byron/GitPython
and cloned using:
-git clone git://gitorious.org/git-python/mainline.git git-python
git clone git://github.com/Byron/GitPython.git git-python
+DOCUMENTATION
+=============
+The html-compiled documentation can be found at the following URL:
+
+http://packages.python.org/GitPython/
+
MAILING LIST
============
http://groups.google.com/group/git-python
diff --git a/setup.py b/setup.py
index 54d78c50..bafd5003 100755
--- a/setup.py
+++ b/setup.py
@@ -29,8 +29,8 @@ class build_py(_build_py):
class sdist(_sdist):
def make_release_tree (self, base_dir, files):
_sdist.make_release_tree(self, base_dir, files)
- orig = '__init__.py'
- assert path.exists(orig)
+ orig = path.join('git', '__init__.py')
+ assert path.exists(orig), orig
dest = path.join(base_dir, orig)
if hasattr(os, 'link') and path.exists(dest):
os.unlink(dest)