summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--git/__init__.py2
-rw-r--r--test/test_installation.py6
2 files changed, 7 insertions, 1 deletions
diff --git a/git/__init__.py b/git/__init__.py
index 50730742..53440830 100644
--- a/git/__init__.py
+++ b/git/__init__.py
@@ -19,7 +19,7 @@ __version__ = 'git'
def _init_externals():
"""Initialize external projects by putting them into the path"""
if __version__ == 'git' and 'PYOXIDIZER' not in os.environ:
- sys.path.insert(0, osp.join(osp.dirname(__file__), 'ext', 'gitdb'))
+ sys.path.insert(1, osp.join(osp.dirname(__file__), 'ext', 'gitdb'))
try:
import gitdb
diff --git a/test/test_installation.py b/test/test_installation.py
index db14bc84..3b39a328 100644
--- a/test/test_installation.py
+++ b/test/test_installation.py
@@ -1,6 +1,7 @@
# This module is part of GitPython and is released under
# the BSD License: http://www.opensource.org/licenses/bsd-license.php
+import ast
import os
import subprocess
from test.lib import TestBase
@@ -27,3 +28,8 @@ class TestInstallation(TestBase):
self.assertEqual(0, result.returncode, msg=result.stderr or result.stdout or "Can't build - setup.py failed")
result = subprocess.run([self.python, '-c', 'import git'], stdout=subprocess.PIPE, cwd=self.sources)
self.assertEqual(0, result.returncode, msg=result.stderr or result.stdout or "Selftest failed")
+ result = subprocess.run([self.python, '-c', 'import sys;import git; print(sys.path)'], stdout=subprocess.PIPE, cwd=self.sources)
+ syspath = result.stdout.decode('utf-8').splitlines()[0]
+ syspath = ast.literal_eval(syspath)
+ self.assertEqual('', syspath[0], msg='Failed to follow the conventions for https://docs.python.org/3/library/sys.html#sys.path')
+ self.assertTrue(syspath[1].endswith('gitdb'), msg='Failed to add gitdb to sys.path')