diff options
author | Patrick Lucas <plucas@yelp.com> | 2014-05-02 19:14:48 -0700 |
---|---|---|
committer | Patrick Lucas <plucas@yelp.com> | 2014-05-02 19:19:41 -0700 |
commit | a729e8cbc8ca8e056dc40e9af3e6558eec5fe92f (patch) | |
tree | 34c2c0c6c329d0a076dc826679fc782f79d2f91e /setup.py | |
parent | 2415609ce0899ef53e761e7ccb13177782d46c4e (diff) | |
download | kafka-python-a729e8cbc8ca8e056dc40e9af3e6558eec5fe92f.tar.gz |
Remove 'distribute' dependency
This dependency is unnecessary since this project now uses setuptools and
it prevents installing this package with --use-wheel, failing with this
traceback:
$ pip install --use-wheel distribute
Downloading/unpacking distribute
Downloading distribute-0.7.3-cp26-none-linux_x86_64.whl
Requirement already satisfied (use --upgrade to upgrade): setuptools>=0.7 in ./venv/lib/python2.6/site-packages (from distribute)
Cleaning up...
Exception:
Traceback (most recent call last):
File "/home/plucas/lib/python2.6/site-packages/pip/basecommand.py", line 134, in main
status = self.run(options, args)
File "/home/plucas/lib/python2.6/site-packages/pip/commands/install.py", line 241, in run
requirement_set.install(install_options, global_options, root=options.root_path)
File "/home/plucas/lib/python2.6/site-packages/pip/req.py", line 1256, in install
if req.name == 'distribute' and req.installed_version in distribute_req:
File "/home/plucas/lib/python2.6/site-packages/pip/req.py", line 390, in installed_version
return self.pkg_info()['version']
File "/home/plucas/lib/python2.6/site-packages/pip/req.py", line 357, in pkg_info
data = self.egg_info_data('PKG-INFO')
File "/home/plucas/lib/python2.6/site-packages/pip/req.py", line 293, in egg_info_data
filename = self.egg_info_path(filename)
File "/home/plucas/lib/python2.6/site-packages/pip/req.py", line 307, in egg_info_path
filenames = os.listdir(base)
OSError: [Errno 2] No such file or directory: '/home/plucas/build/distribute/pip-egg-info'
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 1 |
1 files changed, 0 insertions, 1 deletions
@@ -22,7 +22,6 @@ setup( name="kafka-python", version="0.9.0", - install_requires=["distribute"], tests_require=["tox", "mock"], cmdclass={"test": Tox}, |