summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index ed8b457bf..d0749985e 100755
--- a/setup.py
+++ b/setup.py
@@ -81,7 +81,7 @@ def git_version():
env['LANGUAGE'] = 'C'
env['LANG'] = 'C'
env['LC_ALL'] = 'C'
- out = subprocess.Popen(cmd, stdout = subprocess.PIPE, env=env).communicate()[0]
+ out = subprocess.Popen(cmd, stdout=subprocess.PIPE, env=env).communicate()[0]
return out
try:
@@ -147,8 +147,8 @@ if not release:
a = open(filename, 'w')
try:
a.write(cnt % {'version': VERSION,
- 'full_version' : FULLVERSION,
- 'git_revision' : GIT_REVISION,
+ 'full_version': FULLVERSION,
+ 'git_revision': GIT_REVISION,
'isrelease': str(ISRELEASED)})
finally:
a.close()
@@ -164,6 +164,7 @@ def configuration(parent_package='',top_path=None):
quiet=True)
config.add_subpackage('numpy')
+ config.add_data_files(('numpy', 'LICENSE.txt'))
config.get_version('numpy/version.py') # sets config.version