summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Simionato <michele.simionato@gmail.com>2018-05-12 05:32:48 +0200
committerMichele Simionato <michele.simionato@gmail.com>2018-05-12 05:32:48 +0200
commit74e483b40ca47327f1b1fc6605bb2d3f2a99b03f (patch)
treefc0d12cf9a852c7abc410ff21741e43cbf2c8294
parent52923c38b03ffd900c684db551d85c2a954bface (diff)
downloadpython-decorator-git-74e483b40ca47327f1b1fc6605bb2d3f2a99b03f.tar.gz
Fixed references to docs/README.rst
-rw-r--r--MANIFEST.in2
-rw-r--r--Makefile4
-rw-r--r--README.old3
-rw-r--r--setup.py2
4 files changed, 4 insertions, 7 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index b664475..af3dd02 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,2 +1,2 @@
-include docs/README.rst LICENSE.txt CHANGES.md performance.sh documentation.pdf
+include README.rst LICENSE.txt CHANGES.md performance.sh documentation.pdf
recursive-include src/tests *.py
diff --git a/Makefile b/Makefile
index ca45a7a..cbcf307 100644
--- a/Makefile
+++ b/Makefile
@@ -4,8 +4,8 @@ rst: src/tests/documentation.py
PYTHONPATH=src:$(S) $(S)/ms/tools/minidoc.py -d tests.documentation
cp /tmp/tests.documentation.rst docs
-html: /tmp/tests.documentation.rst docs/README.rst
+html: /tmp/tests.documentation.rst
sphinx-build docs docs/_build
-upload: docs/README.rst
+upload: README.rst
python3 setup.py sdist bdist_wheel upload
diff --git a/README.old b/README.old
deleted file mode 100644
index ad68c5a..0000000
--- a/README.old
+++ /dev/null
@@ -1,3 +0,0 @@
-[See the real README](docs/README.rst)
-
-[![Build Status](https://secure.travis-ci.org/micheles/decorator.png?branch=master)](https://travis-ci.org/micheles/decorator)
diff --git a/setup.py b/setup.py
index 6e600a4..5890f4b 100644
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ if __name__ == '__main__':
setup(name='decorator',
version=VERSION,
description='Better living through Python with decorators',
- long_description=open('docs/README.rst').read(),
+ long_description=open('README.rst').read(),
author='Michele Simionato',
author_email='michele.simionato@gmail.com',
url='https://github.com/micheles/decorator',