summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2021-02-27 15:54:04 -0500
committerengn33r <engn33r@users.noreply.github.com>2021-02-27 15:54:04 -0500
commit525cda132b4fd18fad63e7ce19b171d2bca3492a (patch)
tree0facd9139f89400850ed901f47288a702f78d334
parent1ba1c7e21fa5ca42bc04980ddfa1787a99b39f75 (diff)
downloadwebsocket-client-525cda132b4fd18fad63e7ce19b171d2bca3492a.tar.gz
replace 'python setup.py test' with 'pytest'
-rw-r--r--.github/workflows/build.yml22
-rw-r--r--.github/workflows/codecoverage.yml21
2 files changed, 24 insertions, 19 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index c7f4aab..565037f 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -3,23 +3,6 @@ name: Testing GitHub Actions
on: [push]
jobs:
- code-coverage:
- runs-on: ubuntu-latest
- steps:
- - uses: actions/checkout@v2
- - uses: actions/setup-python@v2
- with:
- python-version: 3.9
- - run: |
- pip install six
- TEST_WITH_INTERNET=1 python setup.py test
- pip install coverage
- coverage run --source=websocket --omit="/*/tests/__init__.py","*/tests/test_cookiejar.py","*/tests/test_websocket.py" websocket/tests/test_websocket.py
- coverage report
- coverage xml
- - name: Codecov
- uses: codecov/codecov-action@v1.2.1
-
build:
runs-on: ${{ matrix.os }}
@@ -36,8 +19,9 @@ jobs:
python-version: ${{ matrix.python-version }}
- name: Set up Python ${{ matrix.python-version }} wheel
run: |
- pip install -U pip setuptools wheel twine six
+ pip install -U pip setuptools wheel twine six pytest
python -c "import setuptools; print('Setup tools version'); print(setuptools.__version__)"
+ TEST_WITH_INTERNET=1
+ pytest websocket/tests -v
python setup.py sdist
- TEST_WITH_INTERNET=1 python setup.py test
twine check dist/*
diff --git a/.github/workflows/codecoverage.yml b/.github/workflows/codecoverage.yml
new file mode 100644
index 0000000..d3d8b5c
--- /dev/null
+++ b/.github/workflows/codecoverage.yml
@@ -0,0 +1,21 @@
+name: Code Coverage
+
+on: [push]
+
+jobs:
+ code-coverage:
+ runs-on: ubuntu-latest
+ steps:
+ - uses: actions/checkout@v2
+ - uses: actions/setup-python@v2
+ with:
+ python-version: 3.9
+ - run: |
+ pip install six
+ TEST_WITH_INTERNET=1 python setup.py test
+ pip install coverage
+ coverage run --source=websocket --omit="/*/tests/__init__.py","*/tests/test_cookiejar.py","*/tests/test_websocket.py" websocket/tests/test_websocket.py
+ coverage report
+ coverage xml
+ - name: Codecov
+ uses: codecov/codecov-action@v1.2.1