summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2021-02-27 16:01:34 -0500
committerengn33r <engn33r@users.noreply.github.com>2021-02-27 16:01:34 -0500
commit76b912e8899b2b897c4e1182f8930d3b6161a39d (patch)
tree37bc9791a5377202346ac39673325732222ed5dd
parent525cda132b4fd18fad63e7ce19b171d2bca3492a (diff)
downloadwebsocket-client-76b912e8899b2b897c4e1182f8930d3b6161a39d.tar.gz
Use GitHub Actions environment variable feature
-rw-r--r--.github/workflows/build.yml9
1 files changed, 5 insertions, 4 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index 565037f..ec90752 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -1,4 +1,4 @@
-name: Testing GitHub Actions
+name: websocket-client build and test
on: [push]
@@ -9,7 +9,7 @@ jobs:
strategy:
matrix:
python-version: [3.8, 3.9]
- os: [ubuntu-latest, windows-latest]
+ os: [ubuntu-latest, macOS-latest, windows-latest]
steps:
- uses: actions/checkout@v2
@@ -17,11 +17,12 @@ jobs:
uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python-version }}
- - name: Set up Python ${{ matrix.python-version }} wheel
+ - name: Run websocket-client tests with Python ${{ matrix.python-version }}
run: |
pip install -U pip setuptools wheel twine six pytest
python -c "import setuptools; print('Setup tools version'); print(setuptools.__version__)"
- TEST_WITH_INTERNET=1
pytest websocket/tests -v
python setup.py sdist
twine check dist/*
+ env:
+ TEST_WITH_INTERNET: 1