summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2021-02-27 14:25:46 -0500
committerengn33r <engn33r@users.noreply.github.com>2021-02-27 14:25:46 -0500
commita6de6beea9781b9bb4a426c7a83c59ee3f34e728 (patch)
tree34205db8937e4b16e5f95ca8e9be2a8644977e24
parentb7e8b86e4ad55b0ef807dd04631d5ae1db990be2 (diff)
downloadwebsocket-client-a6de6beea9781b9bb4a426c7a83c59ee3f34e728.tar.gz
Include internet-dependent unit tests
-rw-r--r--.github/workflows/build.yml8
1 files changed, 4 insertions, 4 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index 2672a0d..f963738 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -26,8 +26,8 @@ jobs:
strategy:
matrix:
- python-version: [3.7, 3.8, 3.9]
- os: [ubuntu-latest, macOS-latest, windows-latest]
+ python-version: [3.8, 3.9]
+ os: [ubuntu-latest, windows-latest]
steps:
- uses: actions/checkout@v2
@@ -38,6 +38,6 @@ jobs:
- name: Set up Python ${{ matrix.python-version }} wheel
run: |
pip install -U pip setuptools wheel twine six
- python -c "import setuptools; print(setuptools.__version__)"
- python setup.py install
+ python -c "import setuptools; print("+++Setup tools version: ", str(setuptools.__version__))"
+ TEST_WITH_INTERNET=1 python setup.py test
twine check dist/*