summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2021-02-27 17:02:03 -0500
committerengn33r <engn33r@users.noreply.github.com>2021-02-27 17:02:03 -0500
commitf54fbbb0d91a1c7915f674c3550f7301d895856c (patch)
treeaaa1a56be8ca681c633f73c91ff7c42ce583f1e8
parent0a31687e37e1b7570b5bfa92e8dd637eb1e22321 (diff)
downloadwebsocket-client-f54fbbb0d91a1c7915f674c3550f7301d895856c.tar.gz
Remove end of life Python 3 releases
-rw-r--r--.github/workflows/build.yml10
1 files changed, 2 insertions, 8 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index 5382dd7..b6fc704 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -8,7 +8,7 @@ jobs:
strategy:
matrix:
- python-version: [2.7, 3.4, 3.5, 3.6, 3.7, 3.8, 3.9]
+ python-version: [2.7, 3.6, 3.7, 3.8, 3.9]
os: [ubuntu-latest, macOS-latest, windows-latest]
steps:
@@ -18,15 +18,9 @@ jobs:
uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python-version }}
- - name: Install version 24.0 readme_renderer if Python version == 3.4
- if: ${{ matrix.python-version == '3.4' }}
- run: pip install readme_renderer==24.0
- - name: Install latest readme_renderer if Python version != 3.4
- if: ${{ matrix.python-version != '3.4' }}
- run: pip install -U readme_renderer
- name: Build websocket-client & run tests
run: |
- pip install -U pip setuptools wheel twine six pytest
+ pip install -U pip setuptools wheel readme_renderer twine six pytest
python -c "import setuptools; print('Setup tools version'); print(setuptools.__version__)"
pytest websocket/tests -v -rP
python setup.py sdist