summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2021-01-20 21:02:24 -0500
committerJason R. Coombs <jaraco@jaraco.com>2021-01-20 21:02:24 -0500
commita9ecd7efb38fac3fbbcb6a55feeff10f45793027 (patch)
tree646a63d24354ab17ca71bea038d869fedb49d114 /setup.py
parent8222d6f7b992d3b184434acb31cd66b0f2e41401 (diff)
downloadpython-setuptools-git-feature/remove-easy-install.tar.gz
Remove easy_install script and module.feature/remove-easy-install
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 0 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 28d3dada..866383bd 100755
--- a/setup.py
+++ b/setup.py
@@ -30,22 +30,6 @@ def read_commands():
return command_ns['__all__']
-def _gen_console_scripts():
- yield "easy_install = setuptools.command.easy_install:main"
-
- # Gentoo distributions manage the python-version-specific scripts
- # themselves, so those platforms define an environment variable to
- # suppress the creation of the version-specific scripts.
- var_names = (
- 'SETUPTOOLS_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT',
- 'DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT',
- )
- if any(os.environ.get(var) not in (None, "", "0") for var in var_names):
- return
- tmpl = "easy_install-{shortver} = setuptools.command.easy_install:main"
- yield tmpl.format(shortver='{}.{}'.format(*sys.version_info))
-
-
package_data = dict(
setuptools=['script (dev).tmpl', 'script.tmpl', 'site-patch.py'],
)
@@ -170,7 +154,6 @@ setup_params = dict(
"depends.txt = setuptools.command.egg_info:warn_depends_obsolete",
"dependency_links.txt = setuptools.command.egg_info:overwrite_arg",
],
- "console_scripts": list(_gen_console_scripts()),
"setuptools.installation":
['eggsecutable = setuptools.command.easy_install:bootstrap'],
},