summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 2 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 2bd48daa..0dab158d 100755
--- a/setup.py
+++ b/setup.py
@@ -7,23 +7,13 @@ import os
import sys
import textwrap
+import bootstrap
import setuptools
from setuptools.command.install import install
here = os.path.dirname(__file__)
-def require_metadata():
- "Prevent improper installs without necessary metadata. See #659"
- egg_info_dir = os.path.join(here, 'setuptools.egg-info')
- if not os.path.exists(egg_info_dir):
- msg = (
- "Cannot build setuptools without metadata. "
- "Run `bootstrap.py`."
- )
- raise RuntimeError(msg)
-
-
def read_commands():
command_ns = {}
cmd_module_path = 'setuptools/command/__init__.py'
@@ -192,5 +182,5 @@ setup_params = dict(
if __name__ == '__main__':
# allow setup.py to run from another directory
here and os.chdir(here)
- require_metadata()
+ bootstrap.ensure_egg_info()
dist = setuptools.setup(**setup_params)