summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoah Watkins <noahwatkins@gmail.com>2013-07-21 11:56:48 -0700
committerNoah Watkins <noahwatkins@gmail.com>2013-07-21 12:01:01 -0700
commit48dadae23eb630a7c7abb33c1d2fcb002c8492b1 (patch)
treea562d94ba3338d77fd3c52652b40375cc49890e7 /configure.ac
parent577a142cc91fb09da10804d3e1503e1cf6eb51f6 (diff)
downloadceph-wip-osx-upstream.tar.gz
FileJournal: zero-fill in-lieu of posix_fallocatewip-osx-upstream
Zero-fill journal if posix_fallocate fails or if it is not supported. For very large journals zero fill can take a long time. An optimization is to write a zero byte to the end of each block, or use platform specific features for file allocation. Reference solutions for various platforms can be found in Mozilla, SQLite, and PostgreSQL. Signed-off-by: Noah Watkins <noahwatkins@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8f6b17b86e5..1d628d0a1b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -538,6 +538,8 @@ AC_CHECK_MEMBER([struct stat.st_mtimespec.tv_nsec],
AC_CHECK_FUNC([extattr_set_fd],
[AC_DEFINE(HAVE_EXTATTR, 1, [Define if you have extattr_set_fd])])
+AC_CHECK_FUNCS([posix_fallocate])
+
AC_CHECK_HEADERS([linux/fs.h])
AC_CHECK_HEADERS([sys/disk.h])
AC_CHECK_HEADERS([sys/prctl.h])