summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGary Lowell <glowell@inktank.com>2013-02-15 17:58:48 -0800
committerGary Lowell <glowell@inktank.com>2013-02-26 19:28:48 -0800
commit5397a68f257b9b07c89e85d713696087f84ebe06 (patch)
tree733aad7bb0e6aaaeff58db9b508ae99703c2a61b /configure.ac
parentaa79077c2442e518c11f3d1885461d734909370b (diff)
downloadceph-wip-system-leveldb.tar.gz
Build: Change build to always use system leveldbwip-system-leveldb
Dynamically link to the leveldb installed on the system rather than statically linking ceph copy. Remove the --with-system-leveldb config option, and add a requirement for leveldb libraries for rpm and debian packages. Bug 3945. Signed-off-by: Gary Lowell <gary.lowell@inktank.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 2d445e55b0f..c7bb3d0515c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,6 @@ AC_MSG_NOTICE([RPM_RELEASE='$RPM_RELEASE'])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SUBDIRS([src/gtest])
-AC_CONFIG_SUBDIRS([src/leveldb])
# Environment
AC_CANONICAL_HOST
@@ -413,16 +412,8 @@ AC_ARG_WITH([ocf],
[with_ocf=no])
AM_CONDITIONAL(WITH_OCF, [ test "$with_ocf" = "yes" ])
-# use system leveldb?
-AC_ARG_WITH([system-leveldb],
- [AS_HELP_STRING([--with-system-leveldb], [use system leveldb])],
- ,
- [with_system_leveldb=no])
-AS_IF([test "x$with_system_leveldb" = xyes],
- [AC_CHECK_LIB([leveldb], [leveldb_open], [], [AC_MSG_FAILURE([libleveldb not found])], [-lsnappy -lpthread])])
-AS_IF([test "x$with_system_leveldb" = xcheck],
- [AC_CHECK_LIB([leveldb], [leveldb_open], [with_system_leveldb=yes], [], [-lsnappy -lpthread])])
-AM_CONDITIONAL(WITH_SYSTEM_LEVELDB, [ test "$with_system_leveldb" = "yes" ])
+# use system leveldb
+AC_CHECK_LIB([leveldb], [leveldb_open], [], [AC_MSG_FAILURE([libleveldb not found])], [-lsnappy -lpthread])
# use system libs3?
AC_ARG_WITH([system-libs3],