summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChad Smith <chad.smith@canonical.com>2022-05-09 18:31:51 -0600
committerGitHub <noreply@github.com>2022-05-09 19:31:51 -0500
commit23a1575c6d02c3ffe3c64407de53f0cb7f128fcd (patch)
tree4639eb2c466142adc214c1999c5a74f6722d95e4 /setup.py
parent8d5b841d8b5f1a759f0ea321c1bbe7c87d6dfe72 (diff)
downloadcloud-init-git-23a1575c6d02c3ffe3c64407de53f0cb7f128fcd.tar.gz
upstart: drop vestigial support for upstart (#1421)
upstream cloud-init not longer publishes to distribution versions which support upstart. Trusty has not been receiving cloud-init updates since 0.7.5 and Xenial stopped getting updates as version 21.1. Even though Ubuntu Xenial's default init system is systemd there was still an option for folks to launch amd maintain images which relied on upstart. Now that Xenial no longer has updates from upstream cloud-init we can drop all upstart support. Old Fedora and RHEL releases which use upstart are also not receiving cloud-init updates from tip of main.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 671eb050..7ba0ee8c 100644
--- a/setup.py
+++ b/setup.py
@@ -158,7 +158,6 @@ INITSYS_FILES = {
for f in glob("systemd/*")
if is_f(f) and is_generator(f)
],
- "upstart": [f for f in glob("upstart/*") if is_f(f)],
}
INITSYS_ROOTS = {
"sysvinit": "etc/rc.d/init.d",
@@ -171,7 +170,6 @@ INITSYS_ROOTS = {
"systemd.generators": pkg_config_read(
"systemd", "systemdsystemgeneratordir"
),
- "upstart": "etc/init/",
}
INITSYS_TYPES = sorted([f.partition(".")[0] for f in INITSYS_ROOTS.keys()])