summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBrett Holman <brett.holman@canonical.com>2023-02-28 13:44:48 -0700
committerGitHub <noreply@github.com>2023-02-28 13:44:48 -0700
commit2ee614aa6431f4339f48ebabdf2de4ebcc2401ab (patch)
treee9b7198b8a5b90234b0ca3033c6f39f14550be7f /setup.py
parent6100fda632f63605981636c0900e1e0b8b354979 (diff)
downloadcloud-init-git-2ee614aa6431f4339f48ebabdf2de4ebcc2401ab.tar.gz
dhclient_hook: remove vestigal dhclient_hook command (#2015)
At inception[1], dhclient hooks were used to filter environment variables into /run/cloud-init/dhclient.hooks/<interface>.json which was consumed by WALinuxAgentShim. The fallback method was to parse the dhcp client lease file. Today the Azure datasource directly uses the parsed lease file[2], and loading /run/cloud-init/dhclient.hook/<interface>.json file was removed in 22.2[3]. With no other consumers, we can remove this. [1] https://github.com/canonical/cloud-init/commit/648dbbf6b090c81e989f1ab70bf99f4de16a6a70 [2] https://github.com/canonical/cloud-init/blob/main/cloudinit/sources/DataSourceAzure.py#L447 [3] https://github.com/canonical/cloud-init/commit/5ad0768a796bc07232476d0d29b5225f1e6e131c
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 0 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 04aae5b2..a6dbc5c2 100644
--- a/setup.py
+++ b/setup.py
@@ -316,11 +316,6 @@ if not platform.system().endswith("BSD"):
data_files.extend(
[
- (
- ETC + "/NetworkManager/dispatcher.d/",
- ["tools/hook-network-manager"],
- ),
- (ETC + "/dhcp/dhclient-exit-hooks.d/", ["tools/hook-dhclient"]),
(RULES_PATH + "/udev/rules.d", [f for f in glob("udev/*.rules")]),
(
ETC + "/systemd/system/sshd-keygen@.service.d/",