diff options
author | Simon McVittie <smcv@celebrin.pseudorandom.co.uk> | 2006-11-24 12:58:39 +0000 |
---|---|---|
committer | Simon McVittie <smcv@celebrin.pseudorandom.co.uk> | 2006-11-24 12:58:39 +0000 |
commit | 16d460e5c4987d67a4db248c5fd1a69ca8b0ab23 (patch) | |
tree | cf2a16e7f0e3696b7e3ec703b89552f5c373773f /setup.py | |
parent | 894bafef2cae44d4b41845ed900cffe65dd63900 (diff) | |
download | dbus-python-16d460e5c4987d67a4db248c5fd1a69ca8b0ab23.tar.gz |
setup.py: Don't remove ChangeLog on clean.
Yes, it's generated, but that just means it shouldn't be in the git repo; it
should still appear in tarballs.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 12 |
1 files changed, 1 insertions, 11 deletions
@@ -31,20 +31,10 @@ sys.path.append("dbus") from distutils.core import setup from distutils.extension import Extension -from distutils.command.clean import clean sys.path.append("test") from dbus_python_check import dbus_python_check -def remove(filename): - if os.path.exists(filename): - os.remove(filename) - -class full_clean(clean): - def run(self): - clean.run(self) - remove("ChangeLog") - includedirs_flag = ['-I.'] dbus_includes = ['.', 'include'] dbus_glib_includes = ['.', 'include'] @@ -178,7 +168,7 @@ setup( **extra_ext_args ), ], - cmdclass={'clean': full_clean, 'check': dbus_python_check} + cmdclass={'check': dbus_python_check} ) # vim:ts=4:sw=4:tw=80:si:ai:showmatch:et |